Tunnel eoip entre dos mikrotiks.

Primer de tot el que hem de fer es que els dos routers que faran la vpn arribin a internet.

Per fer això haurem de tenir una ruta 0.0.0.0/0 dirigida cap al router del nostre isp.

Per poder fer la ruta 0.0.0.0/0 contra el router del nostre isp, haurem de tenir una interficie al nostre mikrotik que estigui conectada amb el router del nostre isp.

Molt important perquè el eoip funcioni correctament, hem de posar una ip fixe entre el router isp i el router de guifi.net.

Desprès haurem de realitzar la ruta.

 

 

Com es pot veure a la següent captura aquí estem indicant que tot el que no sapiga on anar ho envii cap al nostre router de isp.

 

Desprès haurem de anar a ip → firewall → nat

Afegirem un masquerade contra la interfície de internet perquè el nostre router de guifi.net vegi internet.

 

Un cop tenim això ja podem realitzar el eoip o vpn com vulgueu dir-li.

El primer que hem de fer es posar el mtu ja que si no tindrem un problema que es que si no varia bé el eoip no es estable. Aquesta seria una banda.

 

 

 

 

 

 

 

 

 

 

 

I aquesta seria l’altre.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Ara ja tindrem el eoip en marxa ara ens falta passar trafic per aquest eoip.

El que farem serà posar un /30 per no gastar gaires ips perquè amb una ip a cada banda en tenim suficient.

 

Selecció_132

Normalment sempre es millor posar la .1 a la mikrotik que te internet i la .2 a la mikrotik a la que volem portar internet.
Ja només ens queda realitzar un masquerade al eoip on volem proveir internet.

 

I fer una ruta 0.0.0.0/0 contra la banda contraria.

 

Ja tindrem el nostre eoip funcionant.

 

SAX!

Crear VPN de mikrotik o debian a ubiquiti

Per fer aixo sencillament hem de crear el tunnel a la nostre debian o mikrotik obrim un rang /30 amb dos ips tenim suficient.

vi /etc/persistent/rc.poststart

insmod ip_gre
ip route add 10.0.0.0/8 via (ip gateway del supernode)
ip tunnel add tunel0 mode gre local (ip del node) remote (ip del server vpn)
ip link set tunel0 up
ip addr add (la ip interna de la vpn) dev tunel0
ip route del default
ip route add default via (ip interna de la vpn del servidor) dev tunel0
iptables -t nat -A POSTROUTING -o tunel0 -j MASQUERADE
iptables -t mangle -A FORWARD -p tcp –tcp-flags SYN SYN -j TCPMSS –set-mss 1436

:wq

chmod +x /etc/persistent/rc.poststart
save
reboot

 

Ya tindrem la VPN funcionant.

Reenviador de correus per el Dude

Primer de tot donar les gracies a l’Eloi Rebes que va ser qui hem va ensenyar a configurar aquest sistema per poder tenir les alertes del programa dude de mikrotik per poguer monitoritzar la xarxa.

sudo apt-get install exim4
cd /etc/exim4/
ls
nano passwd.client

*.google.com:(email):password correu

ls

nano update-exim4.conf.conf

dc_eximconfig_configtype=’smarthost’
dc_other_hostnames=’nom del host’
dc_local_interfaces=’ip local d les interficied’
dc_readhost=’guifi.net’
dc_relay_domains=’*’
dc_minimaldns=’false’
dc_relay_nets=’*’
dc_smarthost=’smtp.gmail.com::587′
CFILEMODE=’644′
dc_use_split_config=’false’
dc_hide_mailname=’true’
dc_mailname_in_oh=’true’
dc_localdelivery=’mail_spool’

Per ultim per comprovar que funciona el reenviador per consola ens enviem un correu al nostre mail mail to (el nostre correu)

Subject: (el que volgueu)

.

Enter

Aneu al vostre correu i haurieu de trobar un mail

 

SAX

Balanceig de Carga WAN Mikrotik

/ip firewall mangle
add chain=input in-interface=(interfacewan1) action=mark-connection new-connection-mark=(interfacewan1)_conn
add chain=input in-interface=(interfacewan2) action=mark-connection new-connection-mark=(interfacewan2)_conn

add chain=output connection-mark=(interfacewan1)_conn action=mark-routing new-routing-mark=to_(interfacewan1)
add chain=output connection-mark=(interfacewan2)_conn action=mark-routing new-routing-mark=to_(interfacewan2)

add chain=prerouting dst-address-type=!local in-interface=(interfacelan) per-connection-classifier=both-addresses­-and-ports:2/0 action=mark-connection new-connection-mark=(interfacewan1)_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=(interfacelan) per-connection-classifier=both-addresses­-and-ports:2/1 action=mark-connection new-connection-mark=(interfacewan2)_conn passthrough=yes

add chain=prerouting connection-mark=(interfacewan1)_conn in-interface=(interfacelan) action=mark-routing new-routing-mark=to_(interfacewan1)
add chain=prerouting connection-mark=(interfacewan2)_conn in-interface=(interfacelan) action=mark-routing new-routing-mark=to_(interfacewan2)

/ip route
add dst-address=0.0.0.0/0 gateway=(iprouterwan1) routing-mark=to_(interfacewan1) check-gateway=ping
add dst-address=0.0.0.0/0 gateway=(iprouterwan2) routing-mark=to_(interfacewan2) check-gateway=ping

add dst-address=0.0.0.0/0 gateway=(iprouterwan1) distance=1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=(iprouterwan2) distance=2 check-gateway=ping

App PingTools

image

Bona Nit avui vinc a parlar-vos de una eina molt util que desde fa poc es va actualitzar inicialment quan la vaig començar a fer servir nomes podies fer ping i traçar rutes ara per el que veig te moltes utlititats i es una de les millors eines per la gestio de una gran xarxa com podria ser la xarxa de guifi.net desde el vostre smartphone o tablet android